大家都知道的原因,Android4.0版本已经步入了历史的红尘,这是官方的统计数据,最新的 2013年2月份的数据

image

以下表格是自已的应用Android4.0版本的统计数据

image

经分析过后,决定不再对Android4.0以下个人应用程序作兼容处理, 默认开发的应用将只针对Android4.0以上的应用程序,因为默认使用了Android3.0以上的holo主题和Viewpager等API, 使用系统自带的ActionBar ,所以对2.3以下的Rom可能不能正常运行

之前因为2.3版本的分布比较多,对ActionBar部分采用了SherlockActionBar 进行了兼容处理,带来的后来就是版本问题,和越来越多的兼容性问题

所以从现在版本过后将不再对4.0以下的Android平台作兼容处理, 把更多的时间集中到产品开发上面来,开发出更多更好用的应用程序..

同时也可以节省apk大小200-500K的体积

之前发布的程序将会更新,如果你的手机是2.3版本或者以下,请不要进行更新

包括:

技术宅壁纸

一键Host

远程桌面客户端

PS: 在公司开发的产品还是得做兼容,因为用户量太大了, 不能舍弃掉这部分用户.